Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Laggy geometry window
11-14-2016, 11:47 PM (This post was last modified: 11-15-2016 02:17 AM by KrisBee.)
Post: #1
Laggy geometry window
So ever since wings version numbers went past 1.5.4, the geometry window has been extremely laggy whenever I work on models with generous poly counts (500000+). I'm guessing this is due to the changed anti-aliasing.

While it is very nice for checking out how the model looks all smoothed out, but for actual work it's a deal breaker. Problem is I can't seem to turn it off for a performance boost; Disabling multi sampling and anti-aliased edges in preferences does nothing to help.

Nvidia control panel settings don't seem to have any kind of effect either on the wings geo window. (Am I missing something here?) Right now I have to stick with 1.5.4 because of said performance problems. That's not a long term solution however. I'd really like to use the latest available version and keep up with all the latest features but I just can't use it for modeling anything big as it is right now.

So can anyone offer any tips?
Reply
11-15-2016, 02:48 AM
Post: #2
RE: Laggy geometry window
I don't think there is anything you can do right now, other than splitting large objects
to have less poly counts per object.

In general I have optimized wings so it should handle large models a lot better now,
the problem is that wings is so loaded that it will never have time to check input from mouse.

I noticed some problem with a 200000 face model this weekend, but I thought no one is using wings with
so many faces...

So if you have a decent gfx card, I don't think disabling AA will help.

When I have time I will do some measurements and try to find a fix.

Thanks for reporting.
Reply
11-15-2016, 03:11 AM (This post was last modified: 11-15-2016 03:16 AM by dgud.)
Post: #3
RE: Laggy geometry window
Some questions is it laggy when you move the camera?

Large selections takes time to draw, so you can disable drawing them in
Preferences/Advanced/Hide Selection While Dragging and While Moving Camera.

Disable Tweak make camera motion faster.
Reply
11-15-2016, 06:49 AM (This post was last modified: 11-15-2016 06:49 AM by KrisBee.)
Post: #4
RE: Laggy geometry window
(11-15-2016 02:48 AM)dgud Wrote:  I don't think there is anything you can do right now, other than splitting large objects
to have less poly counts per object.

In general I have optimized wings so it should handle large models a lot better now,
the problem is that wings is so loaded that it will never have time to check input from mouse.

I noticed some problem with a 200000 face model this weekend, but I thought no one is using wings with
so many faces...

So if you have a decent gfx card, I don't think disabling AA will help.

When I have time I will do some measurements and try to find a fix.

Thanks for reporting.
Oh. Well thanks for the response. I'll just have to stick with the older version for the time being then. It works perfectly fine with the model I'm working on right now and it's pushing well over 600k quads. Still runs smoothly after 2 proxy smooth passes on top of that.


(11-15-2016 03:11 AM)dgud Wrote:  Some questions is it laggy when you move the camera?
It's laggy when moving the camera and when I'm just editing geometry. If it was just camera lag, I could possibly live with that.

(11-15-2016 03:11 AM)dgud Wrote:  Large selections takes time to draw, so you can disable drawing them in
Preferences/Advanced/Hide Selection While Dragging and While Moving Camera.
I usually have very little selected at any given time. For example, just sliding one edge is enough to cause problems.

(11-15-2016 03:11 AM)dgud Wrote:  Disable Tweak make camera motion faster.
I always have tweak off when I'm not using it. So I don't think it's that.
Reply
11-15-2016, 11:00 PM
Post: #5
RE: Laggy geometry window
OS?
Reply
11-16-2016, 01:03 AM
Post: #6
RE: Laggy geometry window
Win10 64
Reply
11-26-2016, 08:18 PM
Post: #7
RE: Laggy geometry window
Can you test and reply in thread
and see if it got any better or worse?
Reply
11-29-2016, 08:33 AM
Post: #8
Thumbsup RE: Laggy geometry window
My response
Reply
02-11-2017, 08:26 PM
Post: #9
RE: Laggy geometry window
Hello, I'm a long time Wings3d user (love it for more than 10 years) and I just updated from version 1.5.3 to 2.x ... BUT the interface has become very slow now. It takes about 1 second every time I right-click before a menu pops up (drives me nuts) and I can literally see the menu is being drawn, line by line. Also, moving the camera around even a default cube primitive is slow and jerky...

I'm on a Windows 7 x64 computer with a fairly old, low-end graphicscard. That may be the main reason, but it never used to be a problem, nor is it a problem in my other 3d apps. The old Wings3d interface was super responsive, so I guess, I will have to stick with 1.5.x for now.

It would be nice to be able to switch back to the old interface in user preferences, but I do understand if that would be a big mess to reimplement. I just don't like it when things degrade, and this seems like a degration... ;-)
Reply
03-02-2017, 03:33 AM
Post: #10
RE: Laggy geometry window
I have both 2.0.5 and 1.0.2 installed (yeah I have been using wings for a long time) 1.0.2 does pretty much all I want to do, but if I want to export to dae, I have to run 2.0.5. Lately I have been trying to model in it, but I have trouble overcoming my aversion to the automatic vert/edge/face selection algorithm. I noticed that models with 10-20k polys seem to noticeably lag the modeling window. 1.0.2 behaves instantly. ( I have a Nvidia gtx 970 card).
The model has many 1024px textures attached to it. I don't know if that creates extra lag for some reason in 2.0.5.
I do like the option of selecting almost any size fonts to make text readable on my 4k monitor.
Any thoughts as to what the problem may be? I have highdpiaware disabled to run the 3d window in native resolution rather than in the 150% windows scaling mode.
I hope this helps.
Reply


Forum Jump:


User(s) browsing this thread: 1 Guest(s)