Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[false+] Wings 2.1.5 won't load files: "Read failed: corrupt Wings file" (Linux)
05-03-2017, 08:25 PM (This post was last modified: 05-22-2017 02:58 PM by micheus.)
Post: #1
[false+] Wings 2.1.5 won't load files: "Read failed: corrupt Wings file" (Linux)
I'm having a problem with Wings 2.1.5 -- most files fail to load, giving me the 'corrupt Wings file' error.

This started happening after an update to Kubuntu 17.04 Linux. I really don't think my files are actually corrupt, as I've loaded them up before, on previous versions of Wings. In fact, I did so a few months ago, without any problems.

I have quite a few old Wings files from several years ago I want to get exported out to Blender, but I can't do that right now with the program rejecting files. I do think it's a bug, and not an issue with my files actually being corrupt.

Anyone have any ideas on how to fix this?
Reply
05-21-2017, 03:09 AM
Post: #2
RE: Wings 2.1.5 won't load files: "Read failed: corrupt Wings file" (Linux)
I'm having the same problem and investigated a bit. It seems that wings has a problems above a certain level of complexity.

I can reproduce the error as follows:
New file, create a torus with x sections and y slices. Save the file. Open the file or Revert.
x=90, y=20 => ok
x=91, y=20 => error

Versions:
System: Gentoo Linux + KDE
NVidia drivers 381.22
wings 2.1.5
erlang 19.1
cl 1.2.3
libsdl 1.2.15
Reply
05-21-2017, 03:32 AM
Post: #3
RE: Wings 2.1.5 won't load files: "Read failed: corrupt Wings file" (Linux)
(05-21-2017 03:09 AM)Loci Wrote:  I can reproduce the error as follows:
New file, create a torus with x sections and y slices. Save the file. Open the file or Revert.
x=90, y=20 => ok
x=91, y=20 => error
That cannot be reproduced in Windows

Quote:Versions:
System: Gentoo Linux + KDE
NVidia drivers 381.22
wings 2.1.5
erlang 19.1
cl 1.2.3
libsdl 1.2.15
Just a comment: SDL isn't used by Wings3D anymore. It was replaced by wxWidgets library.

Let see what dgud can discover about that. Smile

My Wings3D Collection at G+
Reply
05-21-2017, 09:25 PM
Post: #4
RE: Wings 2.1.5 won't load files: "Read failed: corrupt Wings file" (Linux)
(05-21-2017 03:32 AM)micheus Wrote:  
(05-21-2017 03:09 AM)Loci Wrote:  I can reproduce the error as follows:
New file, create a torus with x sections and y slices. Save the file. Open the file or Revert.
x=90, y=20 => ok
x=91, y=20 => error
That cannot be reproduced in Windows
Maybe it's a Linux specific problem. I can't tell. It's just what I found out.
I have no problem working with a torus of this size as long as I don't try to close & reopen it. So maybe it's a problem in the area of saving the file structure or opening it. Unfortunately I didn't find any error messages in the logs.

(05-21-2017 03:32 AM)micheus Wrote:  
Quote:Versions:
System: Gentoo Linux + KDE
NVidia drivers 381.22
wings 2.1.5
erlang 19.1
cl 1.2.3
libsdl 1.2.15
Just a comment: SDL isn't used by Wings3D anymore. It was replaced by wxWidgets library.
It's defined as dependency in the Gentoo ebuild. I have no idea if it's really used or just a leftover from an old version.
Reply
05-21-2017, 10:50 PM
Post: #5
RE: Wings 2.1.5 won't load files: "Read failed: corrupt Wings file" (Linux)
Interesting update: I updated erlang to version 19.3 and now it works.
Reply
05-22-2017, 02:11 AM
Post: #6
RE: Wings 2.1.5 won't load files: "Read failed: corrupt Wings file" (Linux)
Nice. Thanks for the share.

My Wings3D Collection at G+
Reply


Forum Jump:


User(s) browsing this thread: 2 Guest(s)