Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[false+] incorrect version of erl_driver.h
05-15-2017, 11:33 PM (This post was last modified: 05-22-2017 02:58 PM by micheus.)
Post: #1
[false+] incorrect version of erl_driver.h
Wings 2.1.5 crashes on startup. Crashdump:

Code:
Dump written 2017-5-15_15-24
Version: 2.1.5
Window: "<Unknown Window Name>"
Reason: {{load_driver,"Driver compiled with incorrect version of erl_driver.h"},
         [{wxe_server,start,1,[{file,"wxe_server.erl"},{line,65}]},
          {wx,new,1,[{file,"wx.erl"},{line,115}]},
          {wings_theme,native_theme,0,
                       [{file,"c:/Users/familjen/src/wings/src/wings_theme.erl"},
                        {line,89}]},
          {wings_pref,defaults,0,
                      [{file,"c:/Users/familjen/src/wings/src/wings_pref.erl"},
                       {line,380}]},
          {wings_pref,init,0,
                      [{file,"c:/Users/familjen/src/wings/src/wings_pref.erl"},
                       {line,38}]},
          {wings,init,1,
                 [{file,"c:/Users/familjen/src/wings/src/wings.erl"},
                  {line,105}]}]}

system: win 10.0.15063 x64, amd r9 m395x Driver Packaging Version
17.10.2711-170502a-313824E-CrimsonReLive / Radeon Software Version
17.5.1
Reply
05-16-2017, 10:50 PM
Post: #2
RE: incorrect version of erl_driver.h
How are you starting wings?
You must have an old erlang in your path or something, this error is just strange and
indicates you environment is incorrect.
Reply
05-16-2017, 11:35 PM
Post: #3
RE: incorrect version of erl_driver.h
broozar, is that error happening with a fresh install of v2.1.5 or did you have replaced any of .beams files shared for fixing bugs?

My Wings3D Collection at G+
Reply
05-18-2017, 09:17 PM
Post: #4
RE: incorrect version of erl_driver.h
False alarm, sorry. I uninstalled Wings, deleted the preferences.txt, and re-installed it. Now it works again.

For completeness' sake, here are the answers to your questions:
- I installed 2.1.5 into the same directory as 1.5.4 without uninstalling it first.
- It does not matter how Wings is started (Desktop shortcut, start menu, exe directly), the error is (was) the same.
- My $PATH did not contain anything looking like Erlang.
- I do not know what .beams files are Confused

Works now though. Thanks for all your hard work on my favourite modelling software since 0.9 Smile
Reply
05-18-2017, 10:37 PM
Post: #5
RE: incorrect version of erl_driver.h
broozar, thanks for the feedback.

(05-18-2017 09:17 PM)broozar Wrote:  - I installed 2.1.5 into the same directory as 1.5.4 without uninstalling it first.
You definitively should not do that. Wink

Quote:- My $PATH did not contain anything looking like Erlang.
Erland is the language used to build Wings3D. It's virtual machine (erl.exe/werl.exe) is present in "C:\Program Files\wings3d_2.1.5\bin".

Quote:- I do not know what .beams files are Confused
The .beams files are small executables used by Erlang VM (similar to what .jar files are for Java VM)

My Wings3D Collection at G+
Reply


Forum Jump:


User(s) browsing this thread: 1 Guest(s)