Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upgrading Erlang to 20.1 makes Wings crash when creating a cube
11-03-2017, 12:18 AM
Post: #1
Upgrading Erlang to 20.1 makes Wings crash when creating a cube
Hi,

For Erlang 20.0.1, the following steps work fine, while for Erlang 20.1, it crashes Wings:

1. Start wings3d.
2. Create a cube (right click and then select "Cube").

This is for Wings 2.1.5.

I'm on 64-bit Arch Linux, where I maintain both erlang and the wings3d package.

Here is the output on the terminal:

wings-2.1.5
Reading preferences from: /home/afr/.wings3d/preferences.txt
Using GPU shaders.
/usr/bin/wings3d: line 4: 13978 Segmentation fault (core dumped) erl -noinput -smp -pa /usr/lib/erlang/lib/esdl-*/ebin /usr/lib/wings3d/ebin -run wings_start start_halt ${1+"$@"}

I see no core dump file.

Removing ~/.wings3d makes no difference.

Other users have been able to reproduce the problem.

Could this be an issue with Erlang 20.1?

Best regards,
Alexander F Rødseth
Reply
11-04-2017, 12:19 AM (This post was last modified: 11-04-2017 12:21 AM by micheus.)
Post: #2
RE: Upgrading Erlang to 20.1 makes Wings crash when creating a cube
Dan warned me about to use the latest Erlang compiler due a issue related to WxWidgets - not sure it's causing what you are reporting.
Anyway, the current Wings3D version was built using the previous Erlang version - Erlang/OTP 20 - maybe the 19.3, but the 20.0 I have it installed and working - at least on Windows. (download all OSs and versions)

My Wings3D Collection at G+
Reply
11-08-2017, 08:29 PM (This post was last modified: 11-08-2017 08:57 PM by yschaeff.)
Post: #3
RE: Upgrading Erlang to 20.1 makes Wings crash when creating a cube
Same problem on Debian unstable. Had to do the following downgrade to get wings going again.

Will install 9 packages, and remove 1 packages.
1744 kB of disk space will be used
========================================
[REMOVE, NOT USED] erlang-crypto:amd64 1:20.1.4+dfsg-1
[DOWNGRADE] erlang-base:amd64 1:20.1.4+dfsg-1 -> 1:19.2.1+dfsg-2
[DOWNGRADE] erlang-dialyzer:amd64 1:20.1.4+dfsg-1 -> 1:19.2.1+dfsg-2
[DOWNGRADE] erlang-mnesia:amd64 1:20.1.4+dfsg-1 -> 1:19.2.1+dfsg-2
[DOWNGRADE] erlang-runtime-tools:amd64 1:20.1.4+dfsg-1 -> 1:19.2.1+dfsg-2
[DOWNGRADE] erlang-syntax-tools:amd64 1:20.1.4+dfsg-1 -> 1:19.2.1+dfsg-2
[DOWNGRADE] erlang-tools:amd64 1:20.1.4+dfsg-1 -> 1:19.2.1+dfsg-2
[DOWNGRADE] erlang-wx:amd64 1:20.1.4+dfsg-1 -> 1:19.2.1+dfsg-2
[DOWNGRADE] erlang-xmerl:amd64 1:20.1.4+dfsg-1 -> 1:19.2.1+dfsg-2
[DOWNGRADE] wings3d:amd64 2.1.5-2 -> 2.1.5-1
========================================

edit: reported Debian package bug: https://bugs.debian.org/cgi-bin/bugrepor...bug=881156
Reply
11-13-2017, 04:03 AM
Post: #4
RE: Upgrading Erlang to 20.1 makes Wings crash when creating a cube
Yes known bug and will be fixed in the next erlang release, sorry about that.
Reply


Forum Jump:


User(s) browsing this thread: 1 Guest(s)